IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> everything stopped, lost all electrical power in the car
harmoe
post Aug 7 2019, 08:06 AM
Post #1


ATGO Newbie
*

Group: Members
Posts: 1
Joined: 7-August 19
Member No.: 1,537



Restored 1992 firebird 5.0L. getting ready to have the car inspected start the car up let it rub for 5 min. turn the headlights on everything stops no power anywhere. that battery has a full charge. Had to let the car sit over night . Next morning the same thing started died when i turn the head lights on. I let it sit it has sat for 4 days at this time nothing works. Looked for links at the starter they seem to be ok 12+volts. Is there a fusible link for the head light switch, if so where is it located?
Go to the top of the page
 
+Quote Post
BigBadLou
post Aug 7 2019, 10:56 AM
Post #2


Electrical Guru
******

Group: Administrators
Posts: 8,814
Joined: 3-November 04
From: North Austin
Member No.: 7

Tech Writer Lending a Hand Donations award


Welcome from Missouri.
If you were local, I'd offer to look at it but you're too far for that.

In such situations, the first culprit I look at is the battery connection. Those cables are crucial and if they have a bad connection, bridging can occur and cause such weird symptoms.
So I'd clean up both posts, terminals, cables.

Also, you can do a simple diagnosis when all power disappears. Use a voltmeter to follow the power from the battery, through terminals and cables, to the starter solenoid. You are bound to find the break in the chain somewhere.

Let us know what you find.


--------------------
"People suck, life blows, now that's what I call equilibrium!"
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2019 - 02:39 AM